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Used terms, abbreviations and alerts 

 
Terms and abbreviations 

 
 wM-bus - wireless m-bus protocol, EN 13757-4  

 

 AES-128 - symmetric encryption algorithm, in our case CBC 

 
 dBm  -  measurement unit for radio signal quality (dB/mW) 

 

 
 

     Alerts 

 
  

    - Attention, important note 
 

    - Note, Hint 
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 I. General information 
 

WMR-IoT is a wireless m-bus receiver, intended to collect data from various 

devices, working in modes T, S or C according to wireless m-bus standard (EN13757-4). 

This is a protocol, that works in exact frequency range and has several modes of work. 
Its integrated mainly in meters for measurement of water, heat, gas and electricity 

consumption. That is due to nature of work - there is very frequent data transmissions, 

but telegrams are short thus devices can work long time battery powered.  
In normal mode of operation usually meters work only as transmitters (mode T1). 

This means that each meter sends its readout and external device in range should 

'capture' the data and translate everything human readable format. WMR-IoT is exactly 
that kind of device. It is plugged in PC, notebook or tablet through USB interface ((1.1, 

2.0, 3.0). Then WMR-IoT can work as: 

 

� concentrator/reader 
 

� repeater  

 
WMR-IoT has two interfaces: 

� wireless interface  - wM-bus 

� USB interface  - FTDI-based converter USB <-> RS-232 

 
When device works as concentrator all valid telegrams are send to the serial USB 

port. Then proper software (like GinWalk) takes decision what to do with the information 

and how to visualize it for the user.  
 

It can also serve as an wireless repeater, but maximum one hop. In this mode 

device will re-transmit everything in range in order next master/concentrator to read 
data properly.  

In practice, without software WMR-IoT would be unusable. Our software can work 

in two main modes: 

� read and visualize data for every device in range, which is transmitting 
data; 

 

� read and visualize data only for certain list of devices, ignoring all others 
(for instance specific building/entrance/house) 

 

All data is showed in a table and for each meter user can see the following data: 
� meter/device serial number 

� manufacturer code (3-digit) 

� main value (depending on type of the meter) 

� main unit 
� time of readout  

� date of readout 

� signal strength, in dBm 
� status byte (for some devices some bits in this byte are decoded) 

 

As an additional info user can see also: 
� special fields in the telegram (C-field, L-field, etc.) 

� full readio telegram (also saved in log file) 
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� notes on the telegram - encryption type, mode and other stuff 
� up to 16 additional values with measurement units - this is very useful in 

heat metering. There user can see temperatures inlet and outlet, power, 

volume passed, etc. 
 

From the things mentioned above important role can play signal strength 

information. This can be used for fixed networks topology issues. The signal is measured 
in dBm, which means that lower this value is - better coverage. It is showed usually as 

negative number. 

 

 
 Except basic functionality, the program offers some useful functions for advanced 

users: 

� AES-128 CBC decryption, Modes 4 and 5 (7 will be implemented soon) 
� log saving abilities with full radio-telegrams 

� defining of templates for import/export. This is very useful, if the user 

wants to connect wireless readout with certain accounting program 

� saving readed data in local structure database - automatically or manually. 
This gives opportunity for simple date-to-date reports in GinWalk itself 

� saving of readed meters and corresponding AES-128 keys. This gives the 

opportunity to skip loading file for meters readout, because meter ID and 
AES-128 key are memorized and used automatically 

� time record for each readout 

� decryption of some non-OMS meters 
 

Software can be used free of charge. Regular updates are made and uploaded on 

our site. We also can do custom changes by request. 

 
Table 1. Technical specifications of WMR-IoT 

 

№ 

 

Characteristic 
 

Value 

1. RF band 868 - 870 MHz, 12 channels 

2. Wireless m-bus modes T1, T2, S1, S2, C, T1+C (v1), R (v1) 

3. Interface USB 1.1/2.0/3.0 (FTDI drivers) 

4. Serial port speed, bps 19200 bps, None 

5. Power supply 5 Vdc/100mA 

6. Consumption, W < 0.2W 

7. Antenna quarter-wave, center freq. 868 MHz   

17. Work temperature range, °C -20 °C ÷ +50 °C 

22. Dimensions, LxWxH, mm 50x25x15 

23. Protection class, IP IP20 

24. Own weight, g 25 g 
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II. Software GinWalk 

1. General view 

 

Fig. 1. General view of GinWalk 

Main components: 

 1 - main table, filled with read data 

 2 -  tree-view structure, in which a meter and his AES-128 key can be 

localized fast 

 3 - main menu for settings or choice of action 

 4 - button Start/Stop to run/stop reading and searching for meters 

 5 - additional information to current processes 

 

Main table (1) 

Here user can see all important data, read from each device. This is: 

� sequential number in the table 

� meter serial number 

� manufacturer code 
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� auxiliary serial number (if exists, some H/C meters do that) 

� control fields information 

� medium measured 

� main value and its measuring unit 

� notes - this is either free text or AES-128 notes (if message is encrypted) 

� full wireless telegram, in hexadecimal values  

� meter firmware version 

� values for up to 16 additional values in a message 

 

Columns in this table are resizable, using mouse or changing dimensions of the 

program (including Full Screen). In the table using context menu, user can also do the 

following: 

� copy full telegram in hexadecimal values in case user wants to save it 

somewhere (shortcut Ctrl+C) 

� full decoding - shortcut is button F1 

� delete meter from the table - shortcut is button Delete 

� clear whole table 

� enter AES-128 key for a meter or all meters 

� export whole table in CSV format 

� manually save read data in local structure database (file db.dat) 

 

To use the context menu just press right mouse button somewhere over the table. 

It looks like this: 

 

Fig. 2. Context menu main grid 

Export Export data in CSV format. Exports directly all table columns as it 

is. If the user wants to export to custom template, he should use 

the button Export above the table or select this option from menu 
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File 

Clear table Clears the table 

Save in database Writes current table data in local database. Then reports can be 

made for different periods of time 

Copy Full telegram Copies full wireless telegram in Windows Clipboard-a 

Remove selected row Deletes selected meter (the row in Blue color) 

Enter AES-128 key Allows the user to enter manually AES-128 decryption key. The 

code is entered in hexadecimal manner, but with ASCII symbols. 

This means that the code should consist of exactly 32 symbols, 

otherwise it will not be correct. There is a setting allowing the 

program to add automatically '0's, if user does not enter total of 32 

symbols 

 

Meter tree-view (2) 

If user loads data from external file (Import) in this area of the screen user can 

see only meter serial numbers. As a sub-item for each meter is loaded his AES-128 

decryption key, of course if exists in the loaded file. When actual reading starts user can 

see very fast which devices are read and/or decrypted, because there is color chanhges 

for each devices. This depends on is the device read, is the device read and decrypted, is 

there something important to notice about this device.   

If data is not loaded from external file, then in the beginning this tree-view is 

empty. It fills with data among with the table. 

 

Menu (3) 

От менюто могат да се извършват допълнителни (или второстепенни) 

операции, които подпомагат потребителя. Menu has three main functions: 

Menu File - helps user to make export/import, saving log files, exit from the 

program 
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Fig. 3. Menu File 

Import from CSV Import data from external file, CSV in common case. User can 

make and use pre-defined templates for import 

Export data to CSV Save data/export to external file. Again, templates can be used. 

If no - full table is exported 

Save in database Save data in local database (file db.dat). Its structure database 

file. 

Save log file  Save all log messages in text file. Log is memorized in the 

background. It saves all wireless telegrams, messages for 

problems in normal work, etc. From log file user can see and 

identify problems and use it for further processing 

Print table data Prints main fields from the table on a printer, installed and set as 

default in Windows. Format is Landscape in order to capture more 

data 

Exit  Turns off GinWalk, after exit confirmation 

  

Menu Tools - choice for general settings, template definitions for import/export 

of data, reports - if data was saved in local database. 

 

 

Fig. 4. Menu Tools 
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Settings Opens main settings window 

Templates Opens templates window 

Reports Opens Reports window. All reports are made from selected date-

to-date period 

 

Menu Help - gives help :) actually, it opens this Manual 

 

 

About  Gives information about program version and support contacts 

User Manual Opens this Manual 

 

Button Start/Stop (4)  

Runs/Stops reading process of loaded meters or searching new ones. First virtual 

serial port is opened (which should appear when FTDI drivers are installed), then starts 

to listen on the port for data. Current status of serial port and last telegram readout can 

be seen in status bar.  

 

Additional information (status bar) (5)  

Information on current processes - which serial port is used, which is the last read 

meter, how many meters are found, types of meters found, time elapsed from pressing 

button Start, etc. 

 

2. Reading meters 

There are two main ways to use the program: 

- load and read list of specific meters 

- search/read all meters in range of WMR-IoT concentrator 

 

In first case user should load csv file, formatted in certain way. This is 

accomplished by selecting File->Import from CSV. Files can be imported by templates, 

defined from the user (look. p.4. Defining templates for import/export). If not, then 
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loaded file should follow table columns, otherwise meter serial number and AES-128 key 

will not fit in correct table columns. 

Then after pressing button Start program will start to read and decode data from 

WMR-IoT, but will fill data only for the meters in the table.  

In second case user should just press button Start. Then program will add in the 

table each new meter read from the air. This usually is applicable in test scenarios or in 

new buildings readouts.  

In both cases user should set correctly in Tools->Settings serial port number and 

speed (19200, None). 

 

3. Settings 

Main settings window is opened by selecting menu Tools->Settings. 

Settings have two main TAB-s - one for general settings, related to WMR-IoT and 

data decryption, and one for additional data showed for each meter.  

There are two different versions of WMR-IoT: 

� v1 - first revision of device. It is pure hardware (wireless module inside), 

working in all modes; 

� v2 - second revision of device. It has a microcontroller inside and a different 

wireless m-bus hardware, so it can do some additional jobs (decrypt AES-

128, decrypt non-OMS meters automatically, etc.) 

Settings for communicating with WMR-IoT, and direct settings of WMR-IoT mode 

of work, are shown below: 

 

Fig. 5. Settings - general and WMR-IoT settings 
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Serial port settings Virtual serial port settings, after FTDI drivers are installed. If 

drivers are installed correctly - user should see his port 

number/name in Device Manager-> Ports. 

For WMR-IoT speed is ALWAYS 19200bps, and No Parity 

(None).  

Color row last read Choice in what color will be shown last read meter 

Color devices with low battery Choice in what color will be shown a meter with exhausted 

battery (which in fact is coded in Status byte) 

Read meters only ONCE If this checkbox is checked - then each device in the table 

will be read only ONCE. If not checked - then each captured 

telegram is filled in the table, with time and date of reading 

Overwrite field "Notes" This field generally is reserved for some text description of a 

meter (Example: Floor 3, Ap. 2). If this checkbox is checked 

- then this field is overwritten with some additional 

information about reading and encryption process. Mainly 

this is the type of encryption and some other stuff that can 

be useful for solving decoding problems 

Automatically save data on 

Exit 

Choice should all data be automatically saved in local 

database on program exit. If defined so - this happens 

without user notification. If this is not checked - then if user 

wants to save measured data in local database he should 

manually do that from context grid menu (or menu File) 

Settings, related to concentrator WMR-IoT, v1 

Concentrator network type Type of device - either main concentrator/reader or 

REPEATER 

RF strength Signal strength on transmission, in dB (applicable only if 

WMR-IoT will work as repeater) 

Concentrator mode Wireless m-bus Mode of work на WMR-IoT. Possible modes 

of work are Т1, Т2, S1, S2, T1+C, T2+C, R  

Concentrator protocol Data protocol between WMR-IoT and GinWalk. This involves 

only uses of CRC for additional data integrity. Both protocols 

work with GinWalk anyway 

RSSI Option whether concentrator WMR-IoT to transmit 

information about signal strength in the telegram (last 

received telegram for certain meter) 
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Decrypt AES-128 Choice should data be decrypted or not. If this is not 

checked - then user will see raw encrypted telegram in field 

"Full telegram". If is selected for decryption - then user 

should take care to have proper AES-128 keys. This can be 

done in three ways - use Master Key for all meters, enter 

manually key in the table for certain meter/all meters or use 

saved data in Meter database in the program. GinWalk can 

decrypt AES-128 CBC, modes 4 and 5. Mode 7 will also be 

available soon.  

Settings, related to concentrator WMR-IoT, v2 

Wireless m-bus mode Possible modes of work are T1, S1 and C (Frame B) 

Turn Decryption On/Off Set shall WMR-IoT decrypt messages or not 

Save AES-128 key for 

decryption 

If Decryption is ON - then a proper AES-128 key shall be 

saved in WRM-IoT for correct Mode 5 decryption 

RSSI Option whether concentrator WMR-IoT to transmit 

information about signal strength in the telegram (last 

received telegram for certain meter) 

 

User should select first which is his version of WMR-IoT - "v1" or "v2". This is 

done in checkboxes in the upper right corner of settings. Then either one of the 

communication settings will be enabled. If not sure - then press button "Check version". 

Settings, related to additional data in main table for a meter: 

 

Fig. 6. Additional data settings 
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Here user can define how many additional parameters to be decoded and showed 

in readout table. Choice is up to 16 additional values and for each column user can enter 

desired name (stopped for now) for better readability. 

 

4. Defining templates for import/export 

This is interesting function of the program, giving the users possibility to define 

their own rules for importing or exporting data. The basic idea for this is to make 

program compatible with different accounting software's that will process data further. 

Usually each program has its own rules for importing data - each column is specific and 

with specific order. So, we can make template that will match the program that we will 

use for calculating consumption and so on.  

Same is valid for importing list of meters for readout in GinWalk. Because if some 

user have central software for making reports - then its very likely that each building is 

defined there and is easy to export a file. 

This gives in a simple way good flexibility of GinWalk. 

General view of template window can be seen below: 
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Fig. 7. Creating and editing templates for import/export 

User can work in two main modes: 

� Create new template  - button New Template 

� Modify existing template  - button Change template 

For each template user should define following main characteristics: 

� template type  - is it for import or export 

� template name  - user-defined name 

 

Import templates has 4 main fields, that can (and should) be defined for different 

columns: 

� serial number of the meter 

� manufacturer 

� notes (free text, description for example) 

� AES-128 decryption key 

При образци за експорт могат да се избират всички имена на колони от 

основната таблица в главния прозорец на програмата (общо 16). 

 In short, the idea of templates is to tell the program which column 

number from import file to become Serial number, AES-128 key or free text. If 

Export - main things for defining should be serial number, main value, date and 

time. 

Type of each column for export/import is defined from a context menu, which is 

visible on right mouse button click: 
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Fig. 8. Defining data types in templates 

 Example: 

Имаме файл с уреди, които трябва да се прочетат. Той е направен в MSExcel и е 

подреден така (колона по колона): 

 

Meter No; Meter name; Serial number; Value; Date; Time; Description; AES-128 key 

 

If we want to make a template to import the above csv file, we do the following: 

1) Select Tools->Templates 

2) Press button New Template 

3) Choose Column 3 from the table and press right mouse button 

4) From drop-down menu select Column Type->Meter ID 

5) Select column 7, from drop-down menu select Column Type->Notes 

6) select column 8, from drop-down menu select Column Type->AES-128 key 

7) in the left side of the window we type desired name of this template (for example 

hellotemplate 

8) write down this template by pressing button "Save" 

Сега ако затворим този прозорец и отидем в главната част на програмата, можем да 

импортираме файл от този тип. Ако изберем току-що създадения образец като база за 

импортиране - данните за уредите ще се подредят в точните колони в основната таблица. 

След което можем да дадем START на отчитането. 
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За улеснение на потребителя може директно да се зареди CSV файл в таблицата за 

създаване на образец. Така лесно се вижда коя колона е сериен номер, коя е декриптиращ 

ключ и т.н. Това става с избот на опция Load file от конктекстното меню. 

 

 

5. Reports 

If user has selected automatic (or do it manually) save of read data in local 

database, then he has local data that can be reviewed and worked with. Selecting Menu 

Reports user can make simple reports for selected period (date From - date To). 

These reports can be saved/exported to CSV file, which is compatible with 

MSExcel. 
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Fig. 10. Reports from local database 

 

Report is generated always for chosen period of time - From-To and shows most 

of the things that are visualized in main table. Some things are not saved, generally this 

is Full telegram and some not important info for the calculating process. 

The report can also be very useful to 'catch' the time when meter battery has 

become under voltage and so on. 

 

6. Menu Help 

Here there are two options: 

About - opens window that shows current version of the program GinWalk and 

support information contacts 

User Manual - if user has installed PDF reader, then this Manual will be 

automatically opened 
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III. Safety 

 
In normal conditions work with WMR-IoT   is not considered dangerous and it 

covers European regulations for safety. Device is powered from an USB порт (5Vdc, 

100mA). Though, when working with wireless concnetrators of WMR-IoT type, You 

should consider the following: 
 

� FTDI drivers installations should be done by people that knows what is USB 

and what is serial port RS-232; 
 

� Device can be powered by external adapter, when working mode is REPEATER; 

 

� If external USB cable is used and not direct USB connection between WMR-IoT 
and reading device - user should use quality USB cables and not longer than 

3m; 

 
� If Windows is set to save energy (i.e. turns off in 20-30 minutes) keep in mind 

that there will be problems with USB ports after Windows is enabled from 

sleep; 
 

� При почистване на блока първо да се изключи захранващото напрежение! 

Почистването се извършва с мека кърпа, леко навлажнена (не мокра). В 

никакъв случай да не се използуват препарати, съдържащи бензинови и 
ацетонови съставки. 
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IV.Contacts 

 

"GINEERS" Ltd.  

1528, Sofia, Bulgaria 

7, "Iskarsko shausse" blvd., TCE, building 7B 

phone./fax: +359 2 975 81 05 

office@gineers.com 

 
 

 All development (both hardware and software) is made by Gineers. Any 

reasonable changes are possible, again in both hardware and software. 
 

For questions, support and troubleshooting, please refer to 

   support@gineers.com 

 

 


